NASLite Network Attached Storage

www.serverelements.com
Task-specific simplicity with low hardware requirements.
It is currently Tue Jul 23, 2019 4:14 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Wed Apr 26, 2006 6:50 pm 
Offline

Joined: Fri Feb 10, 2006 2:26 am
Posts: 22
I have a program called SageTV (DVR software) that is running on a Windows XP Pro machine. It uses UNC shares to save its video files to. So I have told SageTV to use \\NASVideo1\Disk-1 (dont remember if that is exact syntax) but anyway, I see the video files security is set to a user called NAS-User

The problem is, when I tell SageTV to delete the video files, when I am done watching them, it acts likes its deleting them, but I can see they are still there.

What do I need to do, on the Windows XP machine to delete files from the NASVideo1 computer. I know it must be a NTFS/Permissions/Security problem. I just dont know how to make XP+NASLite happy together.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 01, 2006 9:17 pm 
Offline

Joined: Fri Feb 10, 2006 2:26 am
Posts: 22
Does anyone know how to create the same user on an XP box, that would be the equivalent user to the NAS-User account on the Naslite box?

I thought I read on another post that all files are created as NAS-User on the NASLite computer.

So I tried to create a user called NAS-User on the XP Machine, without any password. And then tried to delete files. No Luck.

I tried mapping drives from the XP machine to the NASLite computer, and still no luck. I cant seem to find a way to delete the files from the NASLite box.

There has got to be an easy way. But I cant seem to figure out how to do that. Seems like no matter what I have tried from the Windows XP machine, that I just get error messages about "Permission Denied, or Access Denied"


I cant keep using this product (which would be REAAAAAAAAALY unfortunate) if I cant delete files from it.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 01, 2006 11:48 pm 
Offline
Site Admin

Joined: Tue Jul 13, 2004 4:11 pm
Posts: 1771
Location: Server Elements
There is no need to create a user on your XP machine since NASLite doesn’t care who you are. It simply assigns the same user to everyone. The reason you are having problems with NASLite is that your windows machine locks files for use and then fails to unlock them. That is not common, but may occur with some applications that tend to be sloppy with the filesystem and leave without cleaning after themselves. ;-)

In order to verify, reboot XP and connect to NASLite via FTP using IE or equivalent. See if you can kill the problem files that way. I assume that the only problems you are having is with the app that you described in the earlier post. If that is the case then the above acessment is in fact correct.

Hope that helps.


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 02, 2006 9:19 am 
Offline

Joined: Thu Apr 06, 2006 5:56 pm
Posts: 82
I use NASLite+ for USB with SageTV on XP Pro and it works flawlessly. There must be somehting odd about your configuration.

I'm running Sage under one of my XP users, not as a service. I don't know if this matters or not, but at least it's a place to start.


Top
 Profile  
 
 Post subject: SageTV
PostPosted: Sun May 07, 2006 12:42 am 
Offline

Joined: Fri Feb 10, 2006 2:26 am
Posts: 22
Thanks for the tip about using SageTV. I am not quite sure why my config isnt allowing me to delete files when using the SageTV interface.

I can use SageTV to delete the movie files on every server except the NASLite + USB server.

I will try to reboot the sagetv server, and then try to delete the files using sagetv.

If that doesnt work, I will try to reboot the sagetv server again, and use ftp client as you pointed out.

I hope to get it working, because I would like to have at least 3 naslite+ servers running as files servers, for all my video files


Top
 Profile  
 
 Post subject:
PostPosted: Sun May 07, 2006 11:27 am 
Offline

Joined: Thu Apr 06, 2006 5:56 pm
Posts: 82
Stupid question I know but ... is your NASLite+ server set to use the same workgroup as the machine running SageTV? If they are not the same I think you will have problems.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group